Is Android supported?

Yes, you will need a device running Android 5 or above.